当前位置:首页 > 程序控 > 正文内容

易语言取键代码包括鼠标键代码源码

紫游2年前 (2018-02-17)程序控1859
.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕, , , QQ:610040471

' 需要组件:时钟1,编辑框1,编辑框2。
_启动窗口.标题 = “取键代码 GetAsyncKeyState”
时钟1.时钟周期 = 50

.子程序 键_当前已按下的键, 整数型, , 返回当前按下键的键代码,没有按键返回"-1"
.局部变量 i, 整数型
.局部变量 D, 整数型

i = 0
.判断循环首 (i ≤ 255)
    D = 键_判断函数调用时指定虚拟键的状态 (i)
    .如果真 (D ≠ 0)
        返回 (i)
        跳出循环 ()
    .如果真结束
    i = i + 1
.判断循环尾 ()
返回 (-1)

.子程序 _时钟1_周期事件

' 监视所有按键
.如果真 (键_当前已按下的键 () ≠ -1)
    时钟1.时钟周期 = 0  ' 停止时钟监视
    _启动窗口.标题 = “取键代码 GetAsyncKeyState :” + 到文本 (键_当前已按下的键 ())  ' 或者 调用另一个子程序()
    时钟1.时钟周期 = 50  ' 开始时钟监视
.如果真结束
' 指定按键1
.如果真 (键_当前已按下的键 () = 1)  ' 1 = 鼠标左键代码
    时钟1.时钟周期 = 0  ' 停止时钟监视
    _启动窗口.标题 = “取键代码 GetAsyncKeyState :鼠标左键代码 = ” + 到文本 (键_当前已按下的键 ())  ' 或者 调用另一个子程序()
    时钟1.时钟周期 = 50  ' 开始时钟监视
.如果真结束
' 指定按键2
.如果真 (键_当前已按下的键 () = 2)  ' 1 = 鼠标左键代码
    时钟1.时钟周期 = 0  ' 停止时钟监视
    _启动窗口.标题 = “取键代码 GetAsyncKeyState :鼠标右键代码 = ” + 到文本 (键_当前已按下的键 ())  ' 或者 调用另一个子程序()
    时钟1.时钟周期 = 50  ' 开始时钟监视
.如果真结束


扫描二维码至手机访问

扫描二维码推送至手机访问。

版权声明:本文由编程开发Blog发布,如需转载请注明出处。

转载请注明出处:https://luoliang.com.cn/?id=8

标签: 易语言
返回列表

没有更早的文章了...

下一篇:易语言_取自身文件md5值

相关文章

易语言_互联网浏览器1.取网页文档对象

.版本 2 .支持库 WebBrowser2 .支持库 spec .支持库 iext .子程序 子程序2 .局部变量 局对象_document, 对象 .局部变量 局对象_parent...

易语言_取自身文件md5值

.版本 2 .支持库 spec .支持库 dp1 .子程序 _按钮1_被单击 .局部变量 字节集, 字节集 字节集 = 读入文件 (取执行文件名 ()) 调试输出 (取数据摘要 (字节集)) 信息...

发表评论

访客

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。